Emails from the Telocall domain are being routed to spam.
Incident Report for Telocall
Resolved
Telocall engineers detected the problem and executed a solution after discovering that one of our servers' SPF Records were missing.
Posted Dec 20, 2022 - 12:15 EST
Investigating
Emails sent from the telocall.com domain are being redirected to spam, resulting in the loss of our voicemail and crucial emails.

Telocall will keep you updated as our investigation continues.
Posted Dec 20, 2022 - 11:48 EST
This incident affected: Telocall.com Domains.