Emails are now working. We are monitoring the situation a bit longer to ensure there are no interruptions with some domains. Thank you for your patience.
Posted Jul 31, 2024 - 11:17 EDT
Update
The website is back online. Some emails are starting to come in, but we are still monitoring the situation, and the issue is not fully resolved. Telocall is considering other options and contemplating a potential move to a new host provider soon. We appreciate your patience as we work through these changes.
Posted Jul 30, 2024 - 20:49 EDT
Investigating
We are currently investigating issues with email services. Some interruptions may occur on telocall.com as we make necessary adjustments to our records. We anticipate that everything will return to normal within the next 48 hours.